您的位置:Oray首页 > 客服中心首页 > 花生壳 > 如何在ROS中设置花生壳服务

如何在ROS中设置花生壳服务

在ROS中使用花生壳动态域名解析服务
建议通过由脚本(Scripts)来实现,再通过日程(Scheduler)来进行定时的刷新。
以下为一个自动获取拨号IP地址并提交到花生壳动态域名解析的例子:

打开Winbox进入到ROS,选择System——Scripts,添加新的脚本,

自定义脚本名称(Name),在Source中输入脚本语句:

帐号下所有的域名都有解析

{
local ipaddr
local server "http://ddns.oray.com"
local par "/ph/update\?&myip=$ipaddr"
local users "username"
local paswd "abc123"
:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd
}

指定某个域名有解析:

{
local ipaddr
local server "http://ddns.oray.com"
local domain "domain.gicp.net"
local par "/ph/update\?&hostname=$domain&myip=$ipaddr"
local users "username"
local paswd "abc123"
:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd
}

注:
①实际使用时,需要将username替换为您的花生壳帐号, abc123替换为您的帐号密码,domain.gicp.net替换为您帐号下需要使用花生壳服务的域名,pppoe-out1替换为您ROS的拨号接口名。
②Terminal界面编辑问号前需加转义字符\,脚本首尾需加{};Source界面的脚本中问号前的转义字符\可加可不加,{}可加可不加,均会生效。

————————————————————————————————————————

脚本添加完成后,需要新增日程来自动执行,通过System- Scheduler新增新的日程

在Interval输入执行间隔,建议如下:
免费服务30分钟;
专业级别5分钟;
商业级别3分钟;
旗舰级别1分钟;
间隔时间越短,在ADSL重新拨号后解析生效时间越快
在On Event栏输入:
:execute DDNS(脚本名称)

最后点击Apply(应用)就可以了!~

若ROS版本为6.0系列,则在On Event栏应当输入:
/system script run DDNS(脚本名称)

上一篇:如何在ddwrt内核路由器中设置花生壳服务       下一篇:如何在tomato中内核路由器设置花生壳服务